# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))//gs;t' <<< "0000000
0000000
000A000
00AB000
AAAB000
ABBB000"