use strict;
my $str = '0000000
0000000
000A000
00AB000
AAAB000
ABBB000';
my $regex = qr/(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";