#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))"
Local $sString = "0000000" & @CRLF & _
"0000000" & @CRLF & _
"000A000" & @CRLF & _
"00AB000" & @CRLF & _
"AAAB000" & @CRLF & _
"ABBB000"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)