re = /(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))/
str = '0000000
0000000
000A000
00AB000
AAAB000
ABBB000'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result