$re = '/(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))/s';
$str = '0000000
0000000
000A000
00AB000
AAAB000
ABBB000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;