const regex = /(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(A)(?:(?=.*?\\n)(?=.*?.).){6}){1,}(?=(A))', 'gs')
const str = `0000000
0000000
000A000
00AB000
AAAB000
ABBB000`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);