using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))";
string substitution = @"";
string input = @"0000000
0000000
000A000
00AB000
AAAB000
ABBB000";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}