import Foundation
let pattern = #"(?:(A)(?:(?=.*?\n)(?=.*?.).){6}){1,}(?=(A))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
0000000
0000000
000A000
00AB000
AAAB000
ABBB000
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)