# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=\bprintf\b|\bfprintf\b)/\/\//gim;t' <<< "printf(\"\nReboot not supported. Exiting instead.\n\");
fprintf(stderr, \"FATAL: operation not supported!\n\");"