const regex = new RegExp('(?=\\bprintf\\b|\\bfprintf\\b)', 'gim')
const str = `printf("\\nReboot not supported. Exiting instead.\\n");
fprintf(stderr, "FATAL: operation not supported!\\n");`;
const subst = `//`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);