$re = '/(?=\bprintf\b|\bfprintf\b)/im';
$str = 'printf("\\nReboot not supported. Exiting instead.\\n");
fprintf(stderr, "FATAL: operation not supported!\\n");';
$subst = "//";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;