import Foundation
let pattern = #"(?=\bprintf\b|\bfprintf\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
printf("\nReboot not supported. Exiting instead.\n");
fprintf(stderr, "FATAL: operation not supported!\n");
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"//"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)