using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\bprintf\b|\bfprintf\b)";
string substitution = @"//";
string input = @"printf(""\nReboot not supported. Exiting instead.\n"");
fprintf(stderr, ""FATAL: operation not supported!\n"");";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}