import re
regex = re.compile(r"(?=\bprintf\b|\bfprintf\b)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("printf(\"\\nReboot not supported. Exiting instead.\\n\");\n"
"fprintf(stderr, \"FATAL: operation not supported!\\n\");")
subst = "//"
result = regex.sub(subst, test_str)
if result:
print(result)