re = /(?=\bprintf\b|\bfprintf\b)/im
str = 'printf("\\nReboot not supported. Exiting instead.\\n");
fprintf(stderr, "FATAL: operation not supported!\\n");'
subst = '//'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result