# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(div)>\[([^\]]*)\]<\\/\1>/<\1 class="\2">/gm;t' <<< "foo
<div>[code]</div>
<bar>
"