$re = '/<(div)>\[([^\]]*)\]<\/\1>/m';
$str = 'foo
<div>[code]</div>
<bar>
';
$subst = "<\1 class=\"\2\">";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;