using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(div)>\[([^\]]*)\]<\/\1>";
string substitution = @"<\1 class=""\2"">";
string input = @"foo
<div>[code]</div>
<bar>
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}