re = /<(div)>\[([^\]]*)\]<\/\1>/m
str = 'foo
<div>[code]</div>
<bar>
'
subst = '<\\1 class="\\2">'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result