#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<(div)>\[([^\]]*)\]<\/\1>"
Local $sString = "foo" & @CRLF & _
"<div>[code]</div>" & @CRLF & _
"<bar>" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "<\1 class="\2">"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)