const regex = /<(div)>\[([^\]]*)\]<\/\1>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(div)>\\[([^\\]]*)\\]<\\\/\\1>', 'gm')
const str = `foo
<div>[code]</div>
<bar>
`;
const subst = `<\1 class="\2">`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);