use strict;
my $str = 'foo
<div>[code]</div>
<bar>
';
my $regex = qr/<(div)>\[([^\]]*)\]<\/\1>/mp;
my $subst = '<\\1 class="\\2">';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";