import Foundation
let pattern = #"<(div)>\[([^\]]*)\]<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
foo
<div>[code]</div>
<bar>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<\1 class="\2">"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)