#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^style="url\((['"])?(?:\.\.)?(?<url>[^'"]+)\1?\)""
Local $sString = "style="url(/test.png)"" & @CRLF & _
"style="url("/test.png")"" & @CRLF & _
"style="url('/test.png')"" & @CRLF & _
"style="url(../test.png)"" & @CRLF & _
"style="url("../test.png")"" & @CRLF & _
"style="url('../test.png')""
Local $sSubst = "style="url($1http://mysite.com$2$1)""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)