$re = '/^style="url\(([\'"])?(?:\.\.)?(?<url>[^\'"]+)\1?\)"/m';
$str = 'style="url(/test.png)"
style="url("/test.png")"
style="url(\'/test.png\')"
style="url(../test.png)"
style="url("../test.png")"
style="url(\'../test.png\')"';
$subst = "style=\"url($1http://mysite.com$2$1)\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;