const regex = /^style="url\((['"])?(?:\.\.)?(?<url>[^'"]+)\1?\)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^style="url\\(([\'"])?(?:\\.\\.)?(?<url>[^\'"]+)\\1?\\)"', 'gm')
const str = `style="url(/test.png)"
style="url("/test.png")"
style="url('/test.png')"
style="url(../test.png)"
style="url("../test.png")"
style="url('../test.png')"`;
const subst = `style="url($1http://mysite.com$2$1)"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);