re = /^style="url\((['"])?(?:\.\.)?(?<url>[^'"]+)\1?\)"/m
str = 'style="url(/test.png)"
style="url("/test.png")"
style="url(\'/test.png\')"
style="url(../test.png)"
style="url("../test.png")"
style="url(\'../test.png\')"'
subst = 'style="url($1http://mysite.com$2$1)"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result