import Foundation
let pattern = #"^style="url\((['"])?(?:\.\.)?(?<url>[^'"]+)\1?\)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
style="url(/test.png)"
style="url("/test.png")"
style="url('/test.png')"
style="url(../test.png)"
style="url("../test.png")"
style="url('../test.png')"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"style="url($1http://mysite.com$2$1)""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)