using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^style=""url\((['""])?(?:\.\.)?(?<url>[^'""]+)\1?\)""";
string substitution = @"style=""url($1http://mysite.com$2$1)""";
string input = @"style=""url(/test.png)""
style=""url(""/test.png"")""
style=""url('/test.png')""
style=""url(../test.png)""
style=""url(""../test.png"")""
style=""url('../test.png')""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}