const regex = /(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\+33|\\(\\+33\\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})', 'gm')
const str = `0123456789
+33123456789
(+33)4 98 74 44 44
`;
const subst = `0$1 $2 $3 $4 $5`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);