// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})").unwrap();
let string = "0123456789
+33123456789
(+33)4 98 74 44 44
";
let substitution = "0$1 $2 $3 $4 $5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}