$re = '/(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})/m';
$str = '0123456789
+33123456789
(+33)4 98 74 44 44
';
$subst = "0$1 $2 $3 $4 $5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;