import Foundation
let pattern = #"(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0123456789
+33123456789
(+33)4 98 74 44 44
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1 $2 $3 $4 $5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)