use strict;
my $str = '0123456789
+33123456789
(+33)4 98 74 44 44
';
my $regex = qr/(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})/mp;
my $subst = '0$1 $2 $3 $4 $5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";