re = /(?:\+33|\(\+33\)|0)(?:-| |)([0-9]{1})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})(?:-| |)([0-9]{2})/m
str = '0123456789
+33123456789
(+33)4 98 74 44 44
'
subst = '0$1 $2 $3 $4 $5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result