# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^|]*\|[^|]*\|)/$1prefix/mg;t' <<< "TEST|Test2|Test3|Test4"