$re = '/^([^|]*\|[^|]*\|)/m';
$str = 'TEST|Test2|Test3|Test4';
$subst = "$1prefix";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;