#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([^|]*\|[^|]*\|)"
Local $sString = "TEST|Test2|Test3|Test4"
Local $sSubst = "$1prefix"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)