using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^|]*\|[^|]*\|)";
string substitution = @"$1prefix";
string input = @"TEST|Test2|Test3|Test4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}