package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^|]*\|[^|]*\|)`)
var str = `TEST|Test2|Test3|Test4`
var substitution = "$1prefix"
fmt.Println(re.ReplaceAllString(str, substitution))
}