use strict;
my $str = 'TEST|Test2|Test3|Test4';
my $regex = qr/^([^|]*\|[^|]*\|)/mp;
my $subst = '$1prefix';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";