const regex = /^([^|]*\|[^|]*\|)/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^|]*\\|[^|]*\\|)', 'mg')
const str = `TEST|Test2|Test3|Test4`;
const subst = `$1prefix`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);