# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(A[^A]*?B[^B]*?C)/[\1]/gm;t' <<< "A|B|A|F|B|C|D|E|F|G
A|B|C|F|B|C|D|E|F|G"