#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(A[^A]*?B[^B]*?C)"
Local $sString = "A|B|A|F|B|C|D|E|F|G" & @CRLF & _
"A|B|C|F|B|C|D|E|F|G"
Local $sSubst = "[\1]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)