$re = '/(A[^A]*?B[^B]*?C)/m';
$str = 'A|B|A|F|B|C|D|E|F|G
A|B|C|F|B|C|D|E|F|G';
$subst = "[\1]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;