import Foundation
let pattern = #"(A[^A]*?B[^B]*?C)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A|B|A|F|B|C|D|E|F|G
A|B|C|F|B|C|D|E|F|G
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[\1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)