package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(A[^A]*?B[^B]*?C)`)
var str = `A|B|A|F|B|C|D|E|F|G
A|B|C|F|B|C|D|E|F|G`
var substitution = "[\1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}