re = /(A[^A]*?B[^B]*?C)/m
str = 'A|B|A|F|B|C|D|E|F|G
A|B|C|F|B|C|D|E|F|G'
subst = '[\\1]'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result