import re
regex = re.compile(r"(A[^A]*?B[^B]*?C)", flags=re.MULTILINE)
test_str = ("A|B|A|F|B|C|D|E|F|G\n"
"A|B|C|F|B|C|D|E|F|G")
subst = "[\\1]"
result = regex.sub(subst, test_str)
if result:
print(result)