#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{1,4}bhp|<td class="something">(.*?)<\/td>)"
Local $sString = "1bhp" & @CRLF & _
"12bhp" & @CRLF & _
"<td class="something">This is a test</td>" & @CRLF & _
"123bhp" & @CRLF & _
"1234bhp"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")